# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[([^\][]*)]\(((?:https?|ftps?|file):\\/\\/[^()]*)\)/<a href="$2">$1<\/a>/gi;t' <<< "Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)"