package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[([^\][]*)]\(((?:https?|ftps?|file):\/\/[^()]*)\)`)
var str = `Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)`
var substitution = "<a href="$2">$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}