using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^\][]*)]\(((?:https?|ftps?|file):\/\/[^()]*)\)";
string substitution = @"<a href=""$2"">$1</a>";
string input = @"Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}