import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\][]*)]\\(((?:https?|ftps?|file):\\/\\/[^()]*)\\)";
final String string = "Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)";
final String subst = "<a href=\"$2\">$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}