// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[([^\][]*)]\(((?:https?|ftps?|file):\/\/[^()]*)\)").unwrap();
let string = "Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)";
let substitution = "<a href=\"$2\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}