import Foundation
let pattern = #"\[([^\][]*)]\(((?:https?|ftps?|file):\/\/[^()]*)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$2">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)