$re = '/\[([^\][]*)]\(((?:https?|ftps?|file):\/\/[^()]*)\)/i';
$str = 'Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)';
$subst = "<a href=\"$2\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;