#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\[([^\][]*)]\(((?:https?|ftps?|file):\/\/[^()]*)\)"
Local $sString = "Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)"
Local $sSubst = "<a href="$2">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)