use strict;
my $str = 'Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)';
my $regex = qr/\[([^\][]*)]\(((?:https?|ftps?|file):\/\/[^()]*)\)/ip;
my $subst = '<a href="$2">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";