const regex = /\[([^\][]*)]\(((?:https?|ftps?|file):\/\/[^()]*)\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^\\][]*)]\\(((?:https?|ftps?|file):\\\/\\\/[^()]*)\\)', 'gi')
const str = `Ethereum’s original token distribution event, managed by the [Ethereum Foundation](https://messari.io/asset/ethereum)`;
const subst = `<a href="$2">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);