# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+:\d+)(\s+[^<]+?)<br>/<span class="time">$1<\/span>$2<br>/gm;t' <<< "1:10 - some text<br>"