use strict;
my $str = '1:10 - some text<br>';
my $regex = qr/(\d+:\d+)(\s+[^<]+?)<br>/mp;
my $subst = '<span class="time">$1</span>$2<br>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";