const regex = /(\d+:\d+)(\s+[^<]+?)<br>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+:\\d+)(\\s+[^<]+?)<br>', 'gm')
const str = `1:10 - some text<br>`;
const subst = `<span class="time">$1</span>$2<br>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);