import Foundation
let pattern = #"(\d+:\d+)(\s+[^<]+?)<br>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1:10 - some text<br>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span class="time">$1</span>$2<br>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)