re = /(\d+:\d+)(\s+[^<]+?)<br>/m
str = '1:10 - some text<br>'
subst = '<span class="time">$1</span>$2<br>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result