// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+:\d+)(\s+[^<]+?)<br>").unwrap();
let string = "1:10 - some text<br>";
let substitution = "<span class=\"time\">$1</span>$2<br>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}