# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\btest1="[^"\s]*\K[^"]+//gm;t' <<< "hi test1=\"12c4 ab3d\" blablabla test1=\"5678 sdfg\"
hi test1=\"12c4 ab3d\" blablabla test1=\"abcd 3456 sdfs 2435\""