using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\btest1=""[^""\s]*\K[^""]+";
string substitution = @"";
string input = @"hi test1=""12c4 ab3d"" blablabla test1=""5678 sdfg""
hi test1=""12c4 ab3d"" blablabla test1=""abcd 3456 sdfs 2435""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}