$re = '/\btest1="[^"\s]*\K[^"]+/m';
$str = 'hi test1="12c4 ab3d" blablabla test1="5678 sdfg"
hi test1="12c4 ab3d" blablabla test1="abcd 3456 sdfs 2435"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;