re = /\btest1="[^"\s]*\K[^"]+/m
str = 'hi test1="12c4 ab3d" blablabla test1="5678 sdfg"
hi test1="12c4 ab3d" blablabla test1="abcd 3456 sdfs 2435"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result