const regex = /\btest1="[^"\s]*\K[^"]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\btest1="[^"\\s]*\\K[^"]+', 'gm')
const str = `hi test1="12c4 ab3d" blablabla test1="5678 sdfg"
hi test1="12c4 ab3d" blablabla test1="abcd 3456 sdfs 2435"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);