import Foundation
let pattern = #"\btest1="[^"\s]*\K[^"]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
hi test1="12c4 ab3d" blablabla test1="5678 sdfg"
hi test1="12c4 ab3d" blablabla test1="abcd 3456 sdfs 2435"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)