#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\btest1="[^"\s]*\K[^"]+"
Local $sString = "hi test1="12c4 ab3d" blablabla test1="5678 sdfg"" & @CRLF & _
"hi test1="12c4 ab3d" blablabla test1="abcd 3456 sdfs 2435""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)