import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\btest1=\"[^\"\\s]*\\K[^\"]+";
final String string = "hi test1=\"12c4 ab3d\" blablabla test1=\"5678 sdfg\"\n"
+ "hi test1=\"12c4 ab3d\" blablabla test1=\"abcd 3456 sdfs 2435\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}