import re
regex = re.compile(r"\btest1=\"[^\"\s]*\K[^\"]+", flags=re.MULTILINE)
test_str = ("hi test1=\"12c4 ab3d\" blablabla test1=\"5678 sdfg\"\n"
"hi test1=\"12c4 ab3d\" blablabla test1=\"abcd 3456 sdfs 2435\"")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)