use strict;
my $str = 'hi test1="12c4 ab3d" blablabla test1="5678 sdfg"
hi test1="12c4 ab3d" blablabla test1="abcd 3456 sdfs 2435"';
my $regex = qr/\btest1="[^"\s]*\K[^"]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";