# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^ ]+?;)|;\w+/\1/g;t' <<< "this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll"