const regex = /([^ ]+?;)|;\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^ ]+?;)|;\\w+', 'g')
const str = `this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);