$re = '/([^ ]+?;)|;\w+/';
$str = 'this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;