re = /([^ ]+?;)|;\w+/
str = 'this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result