// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^ ]+?;)|;\w+").unwrap();
let string = "this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}