import re
regex = re.compile(r"([^ ]+?;)|;\w+")
test_str = "this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)