using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^ ]+?;)|;\w+";
string substitution = @"\1";
string input = @"this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}