use strict;
my $str = 'this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll';
my $regex = qr/([^ ]+?;)|;\w+/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";