#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^ ]+?;)|;\w+"
Local $sString = "this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)