package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^ ]+?;)|;\w+`)
var str = `this >word1 is a special ;word2 with ;word3 &lol;qqqq&gaa;qqq;lll`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}