# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\{uD83C}-\x{DBFF}\x{DC00}-\x{DFFF}]+/<i>$0<\/i>/gm;t' <<< "This is 😛 a test with 🙌 emojis in the 🐦 string
"