using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\{uD83C}-\x{DBFF}\x{DC00}-\x{DFFF}]+";
string substitution = @"<i>$0</i>";
string input = @"This is 😛 a test with 🙌 emojis in the 🐦 string
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}