use strict;
my $str = 'This is 😛 a test with 🙌 emojis in the 🐦 string
';
my $regex = qr/[\{uD83C}-\x{DBFF}\x{DC00}-\x{DFFF}]+/mp;
my $subst = '<i>$0</i>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";