import Foundation
let pattern = #"[\{uD83C}-\x{DBFF}\x{DC00}-\x{DFFF}]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is 😛 a test with 🙌 emojis in the 🐦 string
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<i>$0</i>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)