import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\{uD83C\\}-\\x{DBFF}\\x{DC00}-\\x{DFFF}]+";
final String string = "This is 😛 a test with 🙌 emojis in the 🐦 string\n";
final String subst = "<i>$0</i>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}