re = /[\{uD83C}-\x{DBFF}\x{DC00}-\x{DFFF}]+/m
str = 'This is 😛 a test with 🙌 emojis in the 🐦 string
'
subst = '<i>$0</i>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result