package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\{uD83C}-\x{DBFF}\x{DC00}-\x{DFFF}]+`)
var str = `This is 😛 a test with 🙌 emojis in the 🐦 string
`
var substitution = "<i>$0</i>"
fmt.Println(re.ReplaceAllString(str, substitution))
}