const regex = /[\{uD83C}-\x{DBFF}\x{DC00}-\x{DFFF}]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\{uD83C}-\\x{DBFF}\\x{DC00}-\\x{DFFF}]+', 'gm')
const str = `This is 😛 a test with 🙌 emojis in the 🐦 string
`;
const subst = `<i>$0</i>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);