# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-z])( [a-zA-z])([a-zA-z])/\1\2\3/gm;t' <<< "Relationship to other registered owner
Name of other registered owner
"