import re
regex = re.compile(r"([a-zA-z])( [a-zA-z])([a-zA-z])", flags=re.MULTILINE)
test_str = ("Relationship to other registered owner\n"
"Name of other registered owner\n")
subst = "\\1\\2\\3"
result = regex.sub(subst, test_str)
if result:
print(result)