re = /([a-zA-z])( [a-zA-z])([a-zA-z])/m
str = 'Relationship to other registered owner
Name of other registered owner
'
subst = '\\1\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result