# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*totaldisksize="(\d+(?:,\d+)*)".*/$1/gm;t' <<< "<drives name=\"drive 1\" deviceid=\"\\.\PHYSICALDRIVE0\" interface=\"SCSI\" totaldisksize=\"136,7\">
<drives name=\"drive 1\" deviceid=\"\\.\PHYSICALDRIVE0\" interface=\"SCSI\" totaldisksize=\"1367\">"