package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*totaldisksize="(\d+(?:,\d+)*)".*`)
var str = `<drives name="drive 1" deviceid="\\.\PHYSICALDRIVE0" interface="SCSI" totaldisksize="136,7">
<drives name="drive 1" deviceid="\\.\PHYSICALDRIVE0" interface="SCSI" totaldisksize="1367">`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}