import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*totaldisksize=\"(\\d+(?:,\\d+)*)\".*";
final String string = "<drives name=\"drive 1\" deviceid=\"\\\\.\\PHYSICALDRIVE0\" interface=\"SCSI\" totaldisksize=\"136,7\">\n"
+ "<drives name=\"drive 1\" deviceid=\"\\\\.\\PHYSICALDRIVE0\" interface=\"SCSI\" totaldisksize=\"1367\">";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}